[mrtg] target issue

Justin Shore listuser at vinnie.ksu.ksu.edu
Sat Feb 12 03:00:06 MET 2000

I've tried the /IP:community at device syntax for monitoring dynamic 
ports on our Cisco 3660.  Apparently it doesn't work.  My next 
thought (one that I was thinking about in the beginning) was to use a 
script to return the correct with a command like this:

snmpget bobbit 
ip.ipRouteTable.ipRouteEntry.ipRouteIfIndex. | awk 
'{print $3}'

At the time of writing this, it returns 217 (the current port).  Now 
I'm trying to get MRTG to use that.  I tried making my target this

`that_long command above`:bobbit at

But it bitches at me with this:

Bareword "bobbit" not allowed while "strict subs" in use at (eval 28) line 1.
Array found where operator expected at (eval 28) line 1, at end of line

I tried it with quotes around the whole thing. Didn't work.  I tried 
putting that long command in a shell script.  Nope.  I modified that 
shell script to print the exact target that MRTG wants 
port:commmunity at device.  It hated it; I assume it thought that the 
external command was going to return the 4 it wanted rather than the 
target.  Does anyone know how to make MRTG work this way?  If not, 
can anyone help me write an external script to return those 4 blessed 
values?  I've written many of those scripts before to monitor load, 
disk usage, etc.. but never one to monitor traffic, what MRTG usually 
does for me.  I don't know how to work with ifInOctets to get bytes 
from that (or do I need to?).  Anyone think of anything?  Thanks.  My 
brain is mush...


Justin Shore
K-State Linux Distro Mirror, Sysadmin
macdaddy at vinnie.ksu.ksu.edu

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:mrtg-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/mrtg

More information about the mrtg mailing list