[mrtg] Re: RRDTool

Thomas Brian Granier BrianG at zebec.net
Mon Jul 31 22:28:48 MEST 2000

Thanks.. I got it mostly working. For future sake if someone else has
the same problem I'm including what I did to resolve my problem in this
post. At the bottom I describe the new problem I am now having that I
need help with.

In article <7178DE9E7D46D311ACD90008C740AB13123F50 at zbc102>,
	BrianG at zebec.net (Thomas Brian Granier) writes:

>> I then checked my definition for the config file and it was using the
>> appropriate \\server\share name\file name format. However it wasn't
>> working. My next step was to break the file name and the directory
>> into two seperate with the cfgfile pointing at file name and the cfg
>> file directory pointing at \\server\share name. This didn't work.
>> I mapped a drive to the share and access it in the cfgfile
>> configuration by putting drive://file name and this worked fine.
>I think I found the problem with using \ as path separator. But you
>found a workaround anyway.

I double checked and I did use the correct netbios referencing. I
verified at the DOS prompt and was able to get there manually. I went
with mapping a drive and using the share drive and it worked fine.

>> Now for where I am stuck.. When I pull up the page it appears I am
>> getting all the text and formatting on all of the pages I am supposed
>> be getting, but none of my graphics are showing up at all. I've tried
>> looking through the documentation to find further information on
>> to troubleshoot it. I did notice something with regards to needing a
>> temporary folder and the comment seemed to suggest that it is unknown
>> the tmp variable would work in NT. At any rate, I played around with
>> tmp directory stuff for a little while but didn't get very far.
>First: Do you get any error messages? An error graphs? Or a message
>the web server?

I did not get error messages. The only thing I got was an image graph
that consisted of nothing more than an outlined box with a red x in it
and the words index page or something like that written in it. No image.

>There is a DEBUG variable at the top of the cgi (around line 22). Set
>to one and you should get more verbose error messages if the graph
>display fails. You need the GD.pm perl module for this to work.

I did not attempt to use this...

>If you dont't get that far:
>You can add a switch to the configuration to enable a
>   UseRRDTool: rrdtoollog: /where/to/log/rrdtoolcalls

I added this line. No logs were written. Same problem occurred. I
verified the cfg file was runable by manually running it at the command

>The rrdtool calls contain a file name for the graph file. You might
>to check this path (writable?).
>Next: You can call 14all.cgi directly, e.g.
>    D> perl 14all.cgi cfg=config.cfg target=router1 png=daily > f.png

I did this. It did write the file f.png but it looked exatly like the
images I was already seeing. At this point I began to suspect that it
was having some kind of problem getting to the rrd files. I then checked
my Working Directory in my config file. It was using the netbios server
share folder name in order to access the working directory. This was
working fine from the system doing hte logging. But the seperate system
running IIS might have had difficulties accessing it. Now the working
directory needed to be access the same for both the system doing the
actual logging and on the system serving the web pages.. so what I did
was map a drive on my logging system to a share on itself so that the
drive letter would be equal to the drive letter used to share to that
directory on the web system. Then I changed the working directory to use
the drive:/folder format for the working directory. Once I did this I
pulled up the cgi and I was getting pictures. 

However, I was seeing really strange data. T1 circuits were graphing in
the GB range and stuff like that. I removed all my rrd files, imported
my log file (I have mrtg running the normal way on the same targets I am
monitoring with RRD to compare the graphs and so I don't lose any data
while I am testing the conversion) into my rrd test directory and re-ran
log2rrd. After doing so I reran the cgi and all the graphs came up

Now, for what still isn't working. As time passes the rrd version of the
graphs do not appear to be gathering any new data. When I manually run
the config file from the command prompt I see no errors. Any ideas?

>Strip the first 2 lines from f.png (the HTTP header) and look at the

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list