[mrtg] MRTG and Solaris 2.7

Bruce Dennison dennis_b at popmail.firn.edu
Sat Jun 10 03:33:06 MEST 2000

Hash: SHA1


I cant find information on problems with MRTG and Solaris 2.7 in the
mailing list archive.  Perhaps there are known problems, but I can
find no info.  Heres the deal ....

I have been using MRTG for several years.  First on Solaris 2.4 then
switching over to variuos Linuxs.  I started with MRTG 2.5.3 over
GD1.2, upgraded several times, no problems.  Ran well, wonderful
thing this MRTG.

New job!!  We need network monitoring tools so I begin to set up
MRTG.  All goes well building with newest versions of everything,
MRTG-2.8.12, gd1.8.3 and zlib1.1.3, libpng-1.0.6 ... no errors after
following configure and make instructions.  GCC for the compiler ...
Passes all tests ... gddemo works, etc.

I move everything to the WorkDir. I run cfgmaker against my target
and generate valid cfg file and add a simple WorkDir: directive like
normal.  VERY basic config so far.

In standard mode (not as daemon) I run ./mrtg mrtg.cfg and it behaves
as a normal first time MRTG run ... begins to tell me that it cant
find log file, cant remove old log file, etc for the FIRST target
(interface) in the cfg file.  Then it hangs.  If you then bail out of
the hung process you see that it created the daily and weekly files,
html and log files, etc of the FIRST interface ONLY and then hung. 
Never unhangs ... Top or Truss tells me its gone to sleep, but gives
no errors or indications as to why.

Run as daemon ... it wakes up every 'Interval:', runs against the
FIRST target in my cfg file then waits 'Interval:' and does the one
interface again, but never any more.

I have tested for buggy IOS code levels on the cisco devices
(routers, switches, AS5300's etc) by trying simple single device cfg
files over many different devices ... all behave the same ... first
target of config file, then sleep.

I have build using several backlevel versions of MRTG and gd going
back to gd1.2 and MRTG-2.5.3 which is as old a version as I can find
... same results.  My!!!! Wasnt gd simple back then!!!

I have tried many many tweaks, rebuilds, different versions, etc over
the last week on this and always the same results.

No message or syslog entries ... no errors other than normal first
time startup errors.

My guess is that its a problem with Solaris 2.6 and 2.7. 

Does anyone run MRTG on these versions of Solaris?  Anyone have
problems getting it to work?  Hints, ideas, thoughts etc welcome!

Thanx :)


Version: PGPfreeware 6.5.3 for non-commercial use <http://www.pgp.com>


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org

More information about the mrtg mailing list