[mrtg] External Script Error

Gaurav Sabharwal gaurav at inwire.net
Thu Sep 13 09:26:53 MEST 2001

Hi All,

I am calling an external script from the MRTG config file in order to
monitor CPU utilization of a Sun Solaris server. Running SNMP is not an
option. I am getting the errors below whenever I run MRTG from the cron. If
I run MRTG from the command line no errors and the graphs are produced and
updated too. MRTG is running on a Red Hat 7.1 server. MRTG version is

Start of error log:
2001-09-13 11:20:02 -- Started mrtg
2001-09-13 11:20:03 -- WARNING: Could not get any data from external command
`../../scripts/solaris/cpu.pl hostname_here`
Maybe the external command did not even start. (Illegal seek)

End of error log

Start of Config File:
#My Host CPU Utilization Configuration
Target[host-cpu]: `../../scripts/solaris/cpu.pl hostname_here`
MaxBytes[host-cpu]: 100
YLegend[host-cpu]: % of CPU used
LegendI[host-cpu]:   User:
LegendO[host-cpu]:   System:
Legend1[host-cpu]: User Utilization
Legend2[host-cpu]: System Utilization
Legend3[host-cpu]: Maximal user utilization
Legend4[host-cpu]: Maximal system utilization
Title[host-cpu]: CPU Usage on Host
PageTop[host-cpu]: <H1>CPU Statistics for Host</H1>

End of Config File

Thanks in advance.

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list