[mrtg] MRTG page shows only text

Kjetil Kvig kjetil at catchcom.com
Fri Aug 2 14:56:08 MEST 2002

I am monitoring about 50 routers.
The monitoring/displaying of graphs have worked perfectly until i recently changed the user/group owner in apaches httpd.conf file.
SOME of the graphs still work, but a few of them only display text where the images should have been displayed...
I use routers2.cgi to disply them.
The error message says "permission denied" but i cant see where...even if i chmod all folders to 777, and change owner/group to "apache" (or "nobody" which i also tried).

This is a sample of one of the links on the page:

RRD Error: Opening '/var/www/html/graphs/fd.cfg-' for write: Permission denied

You can visit the configuration verification page here.

RRD: /var/www/html/mrtg/
Device: [fd.cfg] 

Params: /var/www/html/graphs/fd.cfg- --imgformat PNG --base 1024 --lazy -l 0 --interlaced -w 140 -h 100 -s end-1000m --x-grid HOUR:1:HOUR:24:HOUR:2:0:%k --title CPU Percentage for --vertical-label Percentage use DEF:in=/var/www/html/mrtg/ DEF:out=/var/www/html/mrtg/ DEF:min=/var/www/html/mrtg/ DEF:mout=/var/www/html/mrtg/ AREA:in#00cc00 CDEF:down=in,UN,INF,0,IF AREA:down#d0d0d0 HRULE:100#ff0000 PRINT:min:MAX:CPU Max %6.2lf %s, PRINT:in:AVERAGE:Avg %6.2lf %s, PRINT:in:LAST:Last %6.2lf %s 

Kjetil Kvig

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list