[mrtg] Re: Problem with external command

Roth, Gabrielle gabrielle.roth at xo.com
Wed Dec 4 00:23:59 MET 2002

>in new version MRTG (2.9.25) I am not able recive
>answer from external script.
>In configuration I have:
>Target[online]: `mysql -uuser -ppassword -h192.26.2.1
>-N < /usr/local/mrtg/cfg/cout.sql`

>If I run script from command line, then I recive
>correct number, but If I run script from this config,
>then I recive these error message:
>WARNING: Problem with External get 'mysql -uuser
>-ppassword -h192.26.2.1 -N <
>   Expected a Number for 'out' but nothing'
>[mrtg at mrtg[2] cfg]$ /usr/bin/mysql -uuser -ppassword
>-h192.26.2.1 -N < /usr/local/mrtg/cfg/cout.sql
>[mrtg at mrtg[2] cfg]$
>In "old" version MRTG 2.9.12 work script fine.

Are you sure it worked fine?  Your output above shows only one number.  IME,
mrtg requires 4 numbers of output, like so:


The fact that your error message specifically says "Expected a Number for
'out'" is another clue that it's not getting all four values.  Make your
script return the needed values, use an absolute path to mysql ;), then see
what happens.

- mrtg questions sent to me privately will not be answered. -
- please use the list!                                      - 

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list