[mrtg] It really looks like a bug- Was: Rateup dies from Signal 13

Adam Augustine adam_augustine at morinda.com
Fri Feb 8 01:41:38 MET 2002

Ok I have tried all the suggestions I was given here and narrowed the
problem down to one line:

RunAsDaemon: Yes

When I run it from the command line (without the RunAsDaemon line) it works
fine, when I run it in cron (without the RunAsDaemon line), it works fine.
It only has problems when I run it in daemon mode.

This makes me think that something is not quite right with the daemon code
for MRTG, possibly some hard coded number of targets or some kind of timing

Just to do a quick recap, MRTG will not process any new targets. If I add a
new target to the config, MRTG creates all the files except .log, .old, and
the graphs themselves. Even if I run it without the RunAsDaemon line, then
go back and run it with the line, it will not update any of the previously
mentioned files. It simply returns this error:

2002-02-07 14:11:20 -- WARNING: rateup died from Signal 13
 with Exit Value 0 when doing router 'wormhole.morinda.com_serial0_0.122'
 Signal was 13, Returncode was 0

The workaround is to run it from cron, but I really like the daemon mode
(for no good reason that I can think of at the moment).

If anyone can help, I would be very grateful.


> -----Original Message-----
> From: Alex van den Bogaerdt [mailto:alex at slot.hollandcasino.nl]
> Sent: Wednesday, January 09, 2002 4:27 PM
> To: adam_augustine at morinda.com
> Cc: mrtg at list.ee.ethz.ch
> Subject: Re: [mrtg] Rateup dies from Signal 13
> Adam Augustine wrote:
> > 
> > 2002-01-09 13:24:57 -- WARNING: rateup died from Signal 13
> >  with Exit Value 0 when doing router 'brain.morinda.com_ethernet0_0'
> >  Signal was 13, Returncode was 0
> unix manual writes:
> 13  SIGPIPE   Broken pipe: write to pipe with no readers
> This indicates that something fails when writing.
> >                                .... As far as I can tell, 
> it can't create
> > the .log and .old files. ...
> This too.
> Apart from dir permissions (which you have checked) could there be
> other disk problems?  I would expect other error messages but just to
> make sure: is there enough disk space available; are there perhaps
> files (unwritable to mrtg) that happen to have the name of what rateup
> wants to create?
> Other oddities might include strange characters in the config file,
> such as ^M characters when it was edited by some windows client while
> this is a unix system (think samba).
> Just try this:
> Create a subdirectory, in there create (not copy!) a new 
> config file by
> hand (keep it simple) and run mrtg on this config file.  Does 
> this work?
> happy troubleshooting,
> -- 
>    __________________________________________________________________
>  / alex at slot.hollandcasino.nl                  
> alex at ergens.op.het.net \
> | work                                                        
>  private |
> | My employer is capable of speaking therefore I speak only 
> for myself |
> +-------------------------------------------------------------
> ---------+
> | Technical questions sent directly to me will be nuked. Use 
> the list. | 
> +-------------------------------------------------------------
> ---------+
> | http://faq.mrtg.org/                                        
>          |
> | http://rrdtool.eu.org  --> tutorial                         
>          |
> +-------------------------------------------------------------
> ---------+

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list