[mrtg] Re: Woes with mrtg

Dan Mahoney, System Admin danm at prime.gushi.org
Sat Jan 26 01:39:49 MET 2002

On Fri, 25 Jan 2002, Paul C. Williamson wrote:

Tried this, didn't work.

I see that mrtg has some hooks for snmpv2c, which uses 64 bit integers.
Is there any other support for this?  An option like 64bitokay[ezwf]: yes
would be great.

alternatively, I've tried doing this with a disk tool that reported in k,
but I can't figure out how to get the little graphs and the legends to
report in mb, kb, and gb.  I initially used "MB" as my measurement, and
that worked fine with numbers like 8000 MB, but the other drive would
often report things in "KMB".

The documentation for the KMG function is even more confusing, since it

Change the default multiplier prefixes (,k,M,G,T,P). In the tag
ShortLegend define only the basic units. Format: Comma seperated list of
prefixed. Two consecutive commas or a comma at start or end of the line
gives no prefix on this item. Note: If you do not want prefixes, then
leave this line blank.

Example: velocity in nm/s (nanometers per second) displayed in nm/h.

 ShortLegend[ezwf]: m/h
 kMG[ezwf]: n,u,m,,k,M,G,T,P
 options[ezwf]: perhour

So should the options for measuring if the tool reports in k be:

kMG[disk]: k,M,G,T,P


I think on the first couple reads through the documentation, I thought
that you were ONLY replacing the five letters seen above, so the numkMGTP
thing just threw me off.

And if so, why should I EVER see numbers like 8000 showing up, shouldn't
that cause a multiplication?

> I was thinking the MaxBytes was too large.  Maybe put in the actual MaxBytes
> and things will start working.  BTW, what is the largest value MRTG can handle?
> Is it an unsigned 32-bit number?  So that would be 2^32?
> Paul
> >>> Alex van den Bogaerdt <alex at slot.hollandcasino.nl> 01/25/02 04:08AM >>>
> Dan Mahoney, System Admin wrote:
> > 29587538944 (the drive's max cap)
> > 6866031616 (the drive's current usage)
> > harddrive
> > 10:49PM  up 42 days, 19:19, 21 users, load averages: 0.09, 0.22, 0.22
> >
> > But in the logfile it generates I see these lines (which may differ
> > slightly):
> >
> > 1011930397 29587538944 6866023424
> > 1011930397 0 0 0 0
> >
> > indicating it's storing both the real value and a null, and likely parsing
> > the null value last.
> 29587538944 6866023424 are the most recent values received,
> 0 0 0 0 is indicating that the rate is 0.
> As you can see the second line has four entries whereas the first
> line has only two.  This is correct and is not a result of storing
> another input value.
> This second line is a calculation, obviously this fails.
> > Options[diskhdd2]: growright,gauge,noinfo
> You do have gauge as an option so I'd expect this to work.  Perhaps
> the numbers are too big for mrtg to handle, perhaps there are some
> problematic characters in the output.
> Try altering the script so that it returns small values and see if
> that comes through.  If so, you may have to report kilobytes.


"Don't try to out-wierd me.  I get stranger things than you free with my
breakfast cereal."

-Button seen at I-CON XVII (and subsequently purchased)

--------Dan Mahoney--------
Techie,  Sysadmin,  WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144   AIM: LarpGM
Web: http://prime.gushi.org
finger danm at prime.gushi.org
for pgp public key and tel#

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list