[mrtg] Question about monitoring laserjet printers

Clemson, Chris Chris.Clemson at softwareag.co.uk
Mon Jul 8 11:55:00 MEST 2002


I would like to be able to monitor HP Laser printers with mrtg.
So far I've only really used the cfgmaker to setup routers.

I have the mibs for our LJ8100, which seem to load correctly.

The test I am trying to do is to count the total number of pages printed by
the printer.
Using an eval of solarwinds mib browser, which is quite good, the mib
pcl-total-page-count reports a number.
However, when I put the following in an mrtg config file:

pcl-total-page-count&pcl-total-page-count:public at cenpr:
SetEnv[pcl-total-page-count]: MRTG_INT_IP="" MRTG_INT_DESCR="HPPCLPageCount"
MaxBytes[pcl-total-page-count]: 16777215
Title[pcl-total-page-count]: Pagecount
Options[pcl-total-page-count]: nopercent
PageTop[pcl-total-page-count]: <h2>CenPR PCL Pagecount</h2>
YLegend[pcl-total-page-count]: pages

I get the following errors:

D:\mrtg-2.9.18\logfiles\cenpr>perl D:\mrtg-2.9.18\bin\mrtg
ERROR: Target[pcl-total-page-count][_IN_]
ount:public at cenpr:' (warn): Array found where operator expected at (eval 11)
e 1, at end of line
ERROR: Target[pcl-total-page-count][_OUT_]
count:public at cenpr:' (warn): Array found where operator expected at (eval
12) li
ne 1, at end of line
WARNING: Skipping Update of pcl-total-page-count, inlast is not defined
WARNING: Skipping Update of pcl-total-page-count, outlast is not defined

putting a .0 on the end of each pcl-total-page-count on the target line
doesn't help. (different errors are produced)
I have no ideas what all this means, except that it complaining about an
array makes me think there should be something stuck on the end.

I have since tried graphing the number of total errors produced on the
printer to see if this worked any better:

Target[hrdeviceerrors]: hrdeviceerrors.1&hrdeviceerrors.1:public at cenpr:
SetEnv[hrdeviceerrors]: MRTG_INT_IP="" MRTG_INT_DESCR="DeviceErrors"
MaxBytes[hrdeviceerrors]: 16777215
Title[hrdeviceerrors]: Device Errors
Options[hrdeviceerrors]: nopercent
PageTop[hrdeviceerrors]: <h2>CenPR Error Count</h2>
YLegend[hrdeviceerrors]: Errors

No errors occur when running mrtg, and in the log file:

1026121305 431 431
1026121305 0 0 0 0
1026121216 0 0 0 0

is produced, which is correct. 431 errors have occurred on the printer since
the last reboot.
However, nothing is graphed, and only the first line has any values other
than 0, yet I am polling the device every 5 minutes with my script.

Does anyone have any ideas what I am doing wrong?

thank you!


The content of this e-mail is confidential, may contain privileged material
and is intended solely for the recipient(s) named above. If you receive this
in error, please notify Software AG immediately and delete this e-mail.

Software AG (UK) Limited
Registered in England & Wales 1310740
Registered Office: Hudson House, Hudson Way,
Pride Park, Derby DE24 8HS

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list