[mrtg] Re: error when running mrtg

Uve Lokk uve at riigikogu.ee
Fri May 3 15:45:07 MEST 2002


I have experienced almost the same problem with perl 5.6.1-27 and mrtg 2.9.18pre9 (tried 2.9.18pre18 as well).

Old scripts work fine (integrated with rrdtool). So I decided to monitor a Squid server. New scripts generate a decent .html & .png files, but mrtg sends the following error message:

"Use of uninitialized value in string ne at /opt/mrtg/bin/mrtg line 982."

snmpget works fine:
	snmpget -p 3401 x.y.z.w community cacheHttpHits
	enterprises.nlanr.squid.cachePerf.cacheProtoStats.cacheProtoAggregateStats.cacheHttpHits = Counter32: 13901

Uve Lokk,
advanced amateur

-----Original Message-----
From: blabla blabla [mailto:brolmeel at hotmail.com]
Sent: Friday, May 03, 2002 1:38 PM
To: mrtg at list.ee.ethz.ch
Subject: [mrtg] error when running mrtg

each time I run mrtg i get folowing error message several times :

Use of uninitialized value in numeric aq (==) at mrtg line 766

I suppose this could be solved by changing the code but I rather not touch 
it :)
Graphs seem to be generated OK but these lines keep filling up my log file 

I'm using version 2.9.18pre9 (latest at this time)

If any more info is needed plz reply


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list