[mrtg] Re: perl script cannot be executed by MRTG

xzhao2 xzhao2 at dal.ca
Wed Aug 6 17:50:52 MEST 2003

I already made prog-to-run executable for everyone. When I run MRTG, it says 
there are some syntax errors in the script, at the same time, MRTG generates a 
*.maxO file in ThreshDir. If I run MRTG again, no error. If I delete the 
*.maxO temporary file in ThreshDir and run MRTG again, it mentions the same 
syntax error.
Still, MRTG is not treating the script as perl. By the way, perl exists in 
/usr/local. No problem with that.
TIA. Simon

>===== Original Message From Gavin Hamill <gdh at acentral.co.uk> =====
>On Wednesday 06 August 2003 2:49 pm, you wrote:
>> It works very fine. But when I run MRTG against mrtg.cfg, it says the
>> threshold program cannot be executed.
>This is a basic UNIX issue, not really connected with MRTG... you need to set
>the 'executable' bit on your script... try this
>$ chmod a+x /full/path/to/your/script.pl
>Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
>Archive     http://www.ee.ethz.ch/~slist/mrtg
>FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
>WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list