[mrtg] Help with Interface Filters

KBrabble kbrabble at cfl.rr.com
Wed Feb 5 23:10:23 MET 2003


    I seem to be having an issue with the filters that I just can't resolve,
no matter how I move the syntax around.  I am using cfgmaker that came w/
MRTG 2.9.25 on a solorais 8 box w/ perl 5.8.0.  I've never used the filters
before, but I've read all I can find on them, and think I'm doing it
correctly, but maybe I'm missing something.

Here is the entire cfgmaker call from command line:

cfgmaker --ifref=descr --global "Interval: 5" --global "Options[_]:
bits,growright" --global "icondir: /icons/" --global "Xsize[_]:
400" --global "Ysize[_]: 150" --global "WorkDir:
/var/mrtg/rrd/elp/rtr/" --global "LogFormat: rrdtool" --global "PathAdd:
/usr/local/rrdtool/bin" --global "LibAdd:
/usr/local/rrdtool/lib/perl" --global "#RunAsDaemon: Yes" --output
/var/mrtg/config/elp/rtr/<router>.cfg '--if-filter=$default && $if_type!=39
&& $if_type!=53 && $if_type!=134' <community>@<router>:::::2

I've tried it with parenthasis, etc and even the position of the --if-filter
option on the command line and still the same result.  It does ignore the
interfaces that I am wanting it to ignore, which is great.  But it seems to
completely ignore the "$default" directive because suddenly all of my admin
down, loopback and null interfaces show up on my graphs.  I haven't been
able to resolve this.  Any pointers would be greatly appreciated.



Kerry Brabble
Network Engineer
South Region
Road Runner
E-Mail: Kerryb at cfl.rr.com
AIM ID: WileyCo2

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list