[mrtg] Re: Segmentation Fault

Alex van den Bogaerdt alex at ergens.op.het.net
Sun Jan 12 01:36:53 MET 2003

On Sat, Jan 11, 2003 at 11:33:50AM -0800, Nichole Koreen Boscia wrote:

> --log: Called /path/to/bin/rateup /path/to/borders_html/ router_9 1042312521 -Z g 3623381376
> 4094541798 125000000 c #00cc00 #0000ff #006600 #ff00ff k 1000 i
> /path/to/borders_html/router_9-day.png -125000000 -125000000 400 100 1 1 1 300 1 4 1

> If I run the above command manually, it segfaults. I've tried this on OpenBSD
> and Solaris. I've tried newer versions on MRTG. I've removed files, ran, re-ran,

I created a small batch file "something" and put the command in it (using
"target" for the target name).  Then I ran this script:

./something: line 1:  9336 Segmentation fault      rateup /tmp/ target 1042312521 -Z g 3623381376 4094541798 125000000 c

Then I think: where are the colors and the rest?

Next step: escape the hashes, delete the logfile and rerun the command.

Rateup WARNING: rateup could not read the primary log file for target
Rateup WARNING: rateup The backup log file for target was invalid as well
Rateup WARNING: rateup Can't remove target.old updating log file
Rateup WARNING: rateup Can't rename target.log to target.old updating log file

and no more segmentation fault.

Don't know what you're trying to do but it seems to me you're
doing something wrong with the colors.


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list