[mrtg] Working around local director SNMP bugs

Michael Grice grice at binc.net
Tue May 20 21:32:07 MEST 2003

I've looked in the archives but didn't see anything pertaining to this
particular problem (well, except a few other folks who had a similar

I'm having some trouble getting cfgmaker to work with a few Cisco local
directors. Specifically, the local director responds to SNMPv1 packets
with SNMPv2c packets containing the error "unknown snmp-version field

If I tell cfgmaker to use SNMPv2c, on the other hand, the local director
responds to getbulk requests with a "no such name" error. 

At the same time, the local director responds fine to a 

For instance, this will fail:

use SNMP_Session;
@r = snmpwalk('foo at ld.bar.net:::::2', '');

While this will succeed:

@r = snmpget('foo at ld.bar.net:::::2', '');

Both worked fine for other Cisco devices I tried.

I believe all the local directors I'm having trouble with are running
4.2.3 or 4.2.4. Upgrading them will happen in the long-term, but in the
meantime I'm looking for a workaround.

For instance, is there a relatively painless (i.e., does not require
rewriting SNMP_util.pm) way of forcing cfgmaker not to use snmpgetbulk
when using SNMPv2c? 

I could just write them out by hand, I guess, but...



Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list