[mrtg] "long long" compile problem HP-UX 11.00

Briggs, Patrick pbriggs at clinitech.net
Thu Sep 11 21:16:06 MEST 2003

I'm unable to compile mrtg-2.10.4 on HP-UX 11.00 using GCC-3.3.1.  I scanned
this mailing list and see others who have the same error message, but nobody
posted a solution.  configure gives me this error:
checking if long long works here... nope
checking if quad works here... nope

** Ooops, your compiler seems to have issues with long long:

   figure out how to get long long, printf with %lld or %qd and
   strtoll working on your platform.
   probably the  config.log file can give you a hint.

So what is the solution?  I have tried "-D_INCLUDE_LONGLONG" and even tried
CC compile with +DD64 to no avail.

Patrick Briggs
Unix System Administrator
Clinitech Information Resources, Inc.

This e-mail message, including any attachments, is for the sole use of the
intended recipient(s) and may contain confidential or privileged
information.  Any unauthorized review, use, disclosure or distribution is
prohibited.  If you are not the intended recipient, please contact the
sender by reply e-mail and destroy the message.

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list