[mrtg] Re: external script no longer functions...

Eric Brander Eric_Mailing_List at rednarb.com
Wed Dec 15 15:42:53 MET 2004

Evert Meulie wrote:
> Hi everyone!

Hi Evert.

> This has worked fine so far, and still works, but only when I call the
> script manually.

It would appear that the user ID that you run it manually with has 
rights to the appropriate path but maybe the automated method does not?

> In mrtg.conf now all it does is generate the following errors in the
> mrtg-log:
> 2004-12-15 08:50:24 -- Started mrtg with config '/etc/mrtg.conf'
> 2004-12-15 08:50:47 -- WARNING: Could not get any data from external
> command '/usr/local/bin/connection_poll_ssh'
> Maybe the external command did not even start. (Illegal seek)

I think this is the clue here. It probably didn't even start because it 
couldn't reach it.

> The only change I have made to my mrtg.conf is moving part of it
> (relating to other hosts and below this poll in the original log) to a
> separate file which I include with 'Include: mrtg-users.conf'

Now this throws me a bit. This worked fine when you had it in a 
different config file? Yet the error message leads me to think its 
unrelated to moving it to another file. /shrug


Eric Brander
A: Because people read from top to bottom
Q: Why should I not top-post?

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list