[mrtg] mrtg of Cisco routers via Internet fails

tom.voussure at sita.be tom.voussure at sita.be
Tue May 11 14:10:58 MEST 2004


I monitor my network (cisco routers) with MRTG and it workes really

But I have a problem with monitoring routers via Internet.

I have several Internet connection. Some or completely separated from our
main network.

So to monitor these routers, i have to go thru a firewall, on the internet,
to the other router.
(mrtg server --> firewall --> INTERNET --> router)

I always get the same error:
--base: Get Device Info on xxx at
SNMP Error:
no response received
SNMPv1_Session (remote host: "" [].161)
                  community: ""xxx"
                 request ID: -1222128975
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
 at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 570
SNMPWALK Problem for on xxx at
 at /usr/local/mrtg-2/bin/cfgmaker line 709

If a try a snmpget i get also "Timeout, no response from ..."

Now, I'm sure that the snmp settings on the router are correct. The router
is configured the same way as all my other routers.
The firewall settings are also correct. I get no deny's in the logs.

I've also tried changing the packetsize of the snmp-packets send by the
router, but it doesn't help....

Anybody any idea ?


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list