[mrtg] RES: free &used memory are 0?

Eduardo Oliveira Scricco (Service) escricco at rge-rs.com.br
Fri Oct 29 16:28:10 MEST 2004


I tried your script but it didn't worked here.

I have MRTG monitoring memory from my linux box with this simple script:


free -b | grep Mem | while read STR TOTAL USED FREE SHARED BUFFERS
echo $FREE; echo $USED
UPTIME=`uptime | cut -d "," -f1,2 | cut -c14-30`
echo $UPTIME
exit 0

And for swap, you have only to change the "grep" part to "grep Swap"


> -----Mensagem original-----
> De: mrtg-bounce at list.ee.ethz.ch 
> [mailto:mrtg-bounce at list.ee.ethz.ch] Em nome de Marco Ledebur
> Enviada em: sexta-feira, 29 de outubro de 2004 05:16
> Para: mrtg at list.ee.ethz.ch
> Assunto: [mrtg] free &used memory are 0?
> Hello folks!
> I use MRTG-2.10.15 to monitoring the CPU trouble, I/O trouble 
> and free & 
> used memory of my linux machine.
> For all three measurements I use perl scripts.
> CPU & I/O trouble monitoring works fine.
> With a perl script I get the value of the memory from the 
> top-function. I get some value which are right, but the rest 
> of the time free and used memory got the value 0. When I 
> execute the perl script or start mrtg in the terminal it always 
> shows the right values. But MRTG-graphs shows 0.

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list