[mrtg] ThresProg problems in 2.11.1

Håkan Lindholm hakan at staff.spray.se
Wed Apr 6 05:00:10 MEST 2005


I recently upgraded from 2.9.17 to 2.11.1, to give my successor an up-to-date system.
Then threshold scripts stopped working.  I'm pretty sure they are not even executed at all.

Relevant config is:

WorkDir: /var/www/mrtg/switches
Forks: 3
WithPeak[_]: y
Options[_]: growright, bits
Logformat: rrdtool
PathAdd: /usr/local/rrdtool/bin/
LibAdd: /usr/local/rrdtool/lib/perl/
Icondir: /mrtg/
14all*GraphErrorsToBrowser: 1

Target[swacc01_Fa0_1]: #Fa0/1:public at swacc01:::::2
SetEnv[swacc01_Fa0_1]: MRTG_INT_IP="" MRTG_INT_DESCR="FastEthernet0/1"
MaxBytes[swacc01_Fa0_1]: 12500000
Title[swacc01_Fa0_1]: Traffic Analysis for Fa0/1 -- swacc01
PageTop[swacc01_Fa0_1]: <H1>Traffic Analysis for Fa0/1 -- swacc01</H1>
   <TR><TD>System:</TD>     <TD>swacc01 in Esbogatan</TD></TR>
   <TR><TD>Maintainer:</TD> <TD>netdoc at spray.se</TD></TR>
   <TR><TD>Description:</TD><TD>FastEthernet0/1  </TD></TR>
   <TR><TD>ifType:</TD>     <TD>ethernetCsmacd (6)</TD></TR>
   <TR><TD>ifName:</TD>     <TD>Fa0/1</TD></TR>
   <TR><TD>Max Speed:</TD>  <TD>12.5 MBytes/s</TD></TR>

### and so on up to swacc01_Fa0_48

ThreshMaxI[_]: 56250000
ThreshProgI[_]: /usr/local/bin/bb-wrapper-in
ThreshProgOKI[_]: /usr/local/bin/bb-wrapper-in
ThreshMaxO[_]: 56250000
ThreshProgO[_]: /usr/local/bin/bb-wrapper-out
ThreshProgOKO[_]: /usr/local/bin/bb-wrapper-out

Target[swacc01_Gi0_1]: #Gi0/1:public at swacc01:::::2
SetEnv[swacc01_Gi0_1]: MRTG_INT_IP="" MRTG_INT_DESCR="GigabitEthernet0/1"
MaxBytes[swacc01_Gi0_1]: 125000000
Title[swacc01_Gi0_1]: GigabitEthernet0/1 -- swacc01.net.spray.se
PageTop[swacc01_Gi0_1]: <H1>GigabitEthernet0/1 -- swacc01.net.spray.se</H1>
   <TR><TD>System:</TD>     <TD>swacc01.net.spray.se in Esbogatan</TD></TR>
   <TR><TD>Maintainer:</TD> <TD>netdoc at spray.se</TD></TR>
   <TR><TD>Description:</TD><TD>GigabitEthernet0/1  </TD></TR>
   <TR><TD>ifType:</TD>     <TD>ethernetCsmacd (6)</TD></TR>
   <TR><TD>ifName:</TD>     <TD>Gi0/1</TD></TR>
   <TR><TD>Max Speed:</TD>  <TD>125.0 MBytes/s</TD></TR>

### and siumilar for Gi0_1

I tried to add explicit Thresh* settings like this between each gigports MaxBytes and Title:

ThreshMaxI[swacc01_Gi0_1]: 56250000
ThreshProgI[swacc01_Gi0_1]: /usr/local/bin/bb-wrapper-in
ThreshProgOKI[swacc01_Gi0_1]: /usr/local/bin/bb-wrapper-in
ThreshMaxO[swacc01_Gi0_1]: 56250000
ThreshProgO[swacc01_Gi0_1]: /usr/local/bin/bb-wrapper-out
ThreshProgOKO[swacc01_Gi0_1]: /usr/local/bin/bb-wrapper-out

Still not working.

RRD (graphs) looks perfectly fine.

Running "/usr/local/bin/bb-wrapper-in swacc01 1000000 500000" from command line work perfectly fine.

What could the following from CHANGES mean?

Changes 2.9.26
From: André Silveira <ASilveira location multirede.com.br>
* give threshdesc and value as ar 4 and 5 of called threshprog

.. while the configuration reference still says:

"MRTG passes 3 arguments: the $router variable, the threshold value broken, and the current parameter value."

But this shoulds not matter as the script is not executed at all..
(tested by using a one line script to echo Irun to /tmp/Irun)


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list