[mrtg] Snmpget returns correct data but MRTG graphs display zero

Laura Donovan laura at anet.com
Mon Jul 25 22:28:02 MEST 2005


I'm using MRTG to graph data from my Cisco 7206VXR router. Most of the 
graphs are working fine, such as the ones that graph the memory usage. 
But for some reason, the following does not work:

Target[myrouter_numbercalls]: at myrouter
Title[myrouter_numbercalls]: <H1>Number of Active Analog/PPP Calls</H1>
PageTop[myrouter_numbercalls]: <H1>Number of Active Analog/PPP Calls</H1>
Options[myrouter_numbercalls]: growright, gauge, integer, nopercent, bits
YLegend[myrouter_numbercalls]: Number of calls
Legend1[myrouter_numbercalls]: Number of active analog calls
Legend2[myrouter_numbercalls]: Number of active ppp calls
MaxBytes[myrouter_numbercalls]: 1000

I get no errors when I run MRTG, but the graph keeps displaying zero for 
both variables. When I run snmpget from the command line using the same 
OID's, I get the correct values:

#  snmpget -v 1 -c readonly myrouter
SNMPv2-SMI::enterprises. = Gauge32: 186

#  snmpget -v 1 -c readonly myrouter
SNMPv2-SMI::enterprises. = Gauge32: 219

I imagine that if the issue were with the router, the snmpget would 
fail. Also, the other graphs are working fine so I know that the router 
is responding to snmp requests.

Thanks in advance for any assistance!


-Laura DOnovan

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list