[mrtg] Re: Need help with an error

Steve Lindemann steve at marmot.org
Mon Jun 27 21:21:15 MEST 2005

Thank you for replying.  Unfortunately, I had already tried it with \Serial0/0 
in place of \S0/0  (though this has worked before) and had the same problem 
only now it complained about (community string and ip replaced for security):

WARNING: Could not match host:'<rocommunity>@<ip address>:' ref:'Descr' 
ERROR: Target[bud_old][_IN_] ' $target->[7]{$mode} ' did not eval into defined data
ERROR: Target[bud_old][_OUT_] ' $target->[7]{$mode} ' did not eval into defined 

I did take your suggestion to use cfgmaker and as a result I've isolated the 
problem to communications with the router (i.e. my config is probably ok). 
Using your suggestion and a simple default execution I got the same response to 

[mrtg]# cfgmaker --ifref=descr <rocommunity>@<ip address>
[mrtg]# cfgmaker <rocommunity>@<ip address>


--base: Get Device Info on <rocommunity>@<ip address>:
SNMP Error:
no response received
SNMPv1_Session (remote host: "<ip address>" [<ip address>].161)
                   community: "<rocommunity>"
                  request ID: 271753673
                 PDU bufsize: 8000 bytes
                     timeout: 2s
                     retries: 5
                     backoff: 1)
  at /usr/bin//../lib/mrtg2/SNMP_util.pm line 627
SNMPWALK Problem for on <rocommunity>@<ip address>::::::v4only
  at /usr/bin/cfgmaker line 831
WARNING: Skipping <rocommunity>@<ip address>: as no info could be retrieved

If anyone has any suggestions as to how I could best troubleshoot this issue 
I'd appreciate the input.  But for now it appears that my problem is not MRTG 
related and no longer fits this list.  Thanks again!

Steve Lindemann
Network Administrator
Marmot Library Network, Inc.
   url: http://www.marmot.org
email: mailto:steve at marmot.org
voice: 970.242.3331 ext 16
   fax: 970.245.7854

Pavel Ruzicka wrote:
> Hello,
>>WARNING: Could not match host:'<rocommunity>@<ip address>:' ref:'Descr'
>>key:'S0/0' ERROR: Target[bud_old][_IN_] ' $target->[7]{$mode} ' did not
>>eval into defined data ERROR: Target[bud_old][_OUT_] ' $target->[7]{$mode}
>>' did not eval into defined data
> This means, that S0/0 doesn't exists in a snmp tree. This is true, because
> there exists Serial0/0, not S0/0.
> Change your line Target[bud_old]: \S0/0:<rocommunity>@<ip address>:
> to Target[bud_old]: \Serial0/0:<rocommunity>@<ip address>:
> You can generate your config with cfgmaker with option --ifref=descr.
> Best regards,
> Pavel Ruzicka

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list