[mrtg] Error in using SNMPv3 in MRTG

Alvin Anwar alvin.anwar at secureage.com
Wed Aug 30 09:30:58 MEST 2006

I am currently facing a strange error with MRTG when I tried to get some CPU
information from a router. This is the command I'm running inside the bin
	./mrtg ./test.cfg (in Unix) and perl mrtg test.cfg (in Windows)
This is the result of the command, in both Windows and Linux:
	Undefined subroutine &main::snmpget called at mrtg line 2035
I tried to open the mrtg file and this is the command that I found on line
	@ret = snmpget($targtemp,$$target{snmpoptions}, at snmpoids);
I am currently using MRTG version 2.14.5 at the moment. The router currently
only accepts SNMP v 3 only and normal SNMP get query works fine. I'm
attaching the content of the test.cfg in the following:
	WorkDir: c:\www\mrtg
	EnableSnmpV3: yes
Target[test.cpu]:ssCpuRawUser.0&ssCpuRawUser.0:public at
ssCpuRawSystem.0&ssCpuRawSystem.0:public at
ssCpuRawNice.0&ssCpuRawNice.0:public at
	RouterUptime[test.cpu]: public at
	MaxBytes[test.cpu]: 100
	Title[test.cpu]: CPU Load
	PageTop[test.cpu]: <H1>Active CPU Load %</H1>
	Unscaled[test.cpu]: ymwd
	ShortLegend[test.cpu]: %
	YLegend[test.cpu]: CPU Utilization
	Legend1[test.cpu]: Active CPU in % (Load)
	LegendI[test.cpu]: Active
	Options[test.cpu]: growright,nopercent
	SnmpOptions[test.cpu]: authpassword=>'password',authprotocol=>'md5',

Does anyone has a similar problem to what I've had so far?


No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.405 / Virus Database: 268.11.7/432 - Release Date: 29/08/2006

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list