[mrtg] cfgmaker errors - can't locate "cleanhostkey" - using perl

Eric Brander eric_mailing_list at rednarb.com
Tue Feb 21 14:45:17 MET 2006


I have a fresh install of Fedora Core 4 + updates.

I have installed:
mrtg 2.11.1
perl v5.8.6 

Primarily I've been a Windows MRTG & RRDTool user. But I need MORE
POWER, so I'm attempting to convert 100% to Linux. So, out of habit, I

perl cfgmaker comstring at ip.address

I get:

Can't locate object method "cleanhostkey" via package
"comstring at ip.address:" (perhaps you forgot to load
"comstring at ip.address:"?) at cfgmaker line 264.

(community string and ip address hidden of course, that's not what I

Just for grins, and since I saw that cfgmaker is an executable script, I
tried just running it outright - and to my amazement it worked.

What does this mean? Do I have a borked perl install? Was I just doing
it wrong? Can I expect problems in the future?

Thank you for your time.


Eric Brander

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list