[mrtg] SNMPv3 & MRTG cfgmaker

Lamerson, Brian blamerson at stancoe.org
Wed Jul 26 02:20:19 MEST 2006

Hello all.  I am attempting to get SNMPv3 to run on our Cisco equipment
and work with MRTG.  So far I have SNMPv3 working perfectly on the Cisco
equipment.  I applied the following to get it to work:
snmp-server group MRTG v3 priv
snmp-server user MRTG MRTG v3 auth md5 authpassword priv des

I can in turn query it using:

snmpget -v 3 -a md5 -u MRTG -x des -A authpassword -X privpassword -l
authpriv <routerip>

Everytime, it returns the uptime.

However, when I try to use MRTG with it, I receive the following:
perl cfgmaker --global "EnableSnmpV3: yes" --snmp-options=:::::3
--username MRTG --authpassword authpassword --privpassword privpassword

SNMP V3 requires a --username parameter as part of the User Security
Model for router at cfgmaker line 121.

I've tried moving the location of -username, I've tried adding
-username=MRTG, I've tried -username="MRTG" (Windows box).  I've
basically tried all different iterations of it.  Is this a bug with the
cfgmaker program or is it highly picky about something I'm doing?
Obviously SNMPv3 is working on the device from the snmpget command, just
I cannot get the syntax for the cfgmaker command.  While we are a
Windows shop, I have tried running cfgmaker both from a Windows machine
and a Linux machine with the same results.  I'm using MRTG version
2.14.5.  Thanks in advance!! 

Brian Lamerson
Network Specialist
Stanislaus County Office of Education
(209) 525-5018

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list