[mrtg] How to configure mrtg with SNMPv3

Michael Sun michaelsun_ym at yahoo.com
Fri May 5 13:45:43 MEST 2006

I am trying to configure mrtg to work with SNMPv3. I have
installed Net::SNMP and other dependent modules. After that
I  have tried to run cfgmaker with the following options

--global 'WorkDir: /path/to/httpd' 
--global 'Options[_]: bits,growright' 
--global 'EnableSnmpV3: yes' 
--output /path/to/mrtg.cfg 
--username 'censored-user' 
--authprotocol 'sha' 
--authpassword 'censored-pwd' 
--privprotocol 'aescfb128' 
--privpassword 'censored-pwd'  

When running this command I get the following error

| SNMP V3 requires a --username parameter as part of the 
| User Security Model for router public at ip.ip.ip.ip:::::3 
| at /usr/local/mrtg-2/bin/cfgmaker line 121

Since I have stuck with cfgmaker I tried to configure manually
the cfg file and I got problem again. I have tried with something

| EnableIPv6: no
| WorkDir: /path/to/httpd
| Options[_]: bits,growright
| EnableSnmpV3: yes
| Target[ip.ip.ip.ip_1]: 1:ip.ip.ip.ip:::::3
| SnmpOptions[ip.ip.ip.ip_1]: username=>'censored-user',
|                             authprotocol=>'sha',
|                             authpassword=>'censored-pwd',
|                             privprotocol=>'aescfb128',
|                             privpassword=>'censored-pwd'
| SetEnv[ip.ip.ip.ip_1]: MRTG_INT_IP="ip.ip.ip.ip" MRTG_INT_DESCR="eth0"
| MaxBytes[ip.ip.ip.ip_1]: 125000000
| Title[ip.ip.ip.ip_1]: Traffic Analysis for 1 -- Censored
| PageTop[ip.ip.ip.ip_1]: <h1>Traffic Analysis for 1 -- Censored</h1>
| ...

And I get the following:

| Friday, 5 May 2006 at 13:24: ERROR: Target[ip.ip.ip.ip_1][_IN_] '1:ip.ip.ip.ip:::::3' (warn): Bareword "::::" refers to nonexistent package at (eval 15) line 1.
| Friday, 5 May 2006 at 13:24: ERROR: Target[ip.ip.ip.ip_1][_OUT_] '1:ip.ip.ip.ip:::::3' (warn): Bareword "::::" refers to nonexistent package at (eval 16) line 1.

Please note that I could contact ip.ip.ip.ip with some other SNMPv3 tool.
I am using mrtg-2.14.1 on Red Hat Enterprise Linux ES release 4 (Nahant Update 1)

Can someone spot what I did wrong or at least give me a working
configuration file so that I can start somewhere.



Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://lists.ee.ethz.ch/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the mrtg mailing list