[mrtg] Chart never moves.

Gary W. Smith gary at primeexalia.com
Mon Feb 5 17:17:39 CET 2007


That does makes sense.  I know I encountered this problem long ago but I
just couldn't remember how to fix it.  In this case, where the interface
will only go up (soon to be TB range), what should I use for Maxbytes?
Is there a way to say nomaxbytes?  

The current workaround (since the IF is limited to 10mb for this set),
is to just subtract 7fff ffff from the value in a loop until it drops to
a sane number and it seems to work.  I had to take absolute out of the
options and the subtraction method works (thought this is a very bad
kludge workaround).

I will spin up a second copy of this and try it with an arbitrarily
large Maxvalue and run them side by side for a while to compare.


-----Original Message-----
From: Koelstra, J. (Jan) [mailto:JKoelstra at MINSZW.NL] 
Sent: Monday, February 05, 2007 12:46 AM
To: Gary W. Smith; Ed LaFrance; mrtg at lists.oetiker.ch
Subject: RE: [mrtg] Chart never moves.


Nothing wrong with long longs.
The Maxbytes value in your config file is too low.

Everything above the maxbyts value is dropped by MRTG.



-----Original Message-----
From: mrtg-bounces at lists.oetiker.ch
[mailto:mrtg-bounces at lists.oetiker.ch] On Behalf Of Gary W. Smith
Sent: Sunday, February 04, 2007 6:11 PM
To: Ed LaFrance; mrtg at lists.oetiker.ch
Subject: Re: [mrtg] Chart never moves.

> -----Original Message-----
> From: Ed LaFrance [mailto:Ed.LaFrance at newmediaems.com]
> Sent: Sunday, February 04, 2007 7:25 AM
> To: Gary W. Smith; mrtg at lists.oetiker.ch
> Subject: Re: [mrtg] Chart never moves.

> Hello -

> Are you running mrtg at regular intervals? This is typically done with

> the config directive RunAsDaemon (or something like that, check the

> docs), or simply by invoking mrtg every X minutes via a cron job.

> Ed


Yes, I have it cron'd for every 5 minutes.  The problem seems to be
dealing with long long's.  I worked up in the perl script to subtract
4294967296 until it's lower than 4294967296.  That kind of works but I
had odd results.  I tried the same with 2147483647 (I case it was dying
on signed longs) and it also gave me some odd data).

This is with mrtg-2.15.0.  Should this be able to handle long longs?


mrtg mailing list
mrtg at lists.oetiker.ch https://lists.oetiker.ch/cgi-bin/listinfo/mrtg


Dit bericht kan informatie bevatten die niet voor u is bestemd. Indien u
niet de geadresseerde bent of dit bericht abusievelijk aan u is
toegezonden, wordt u verzocht dat aan de afzender te melden en het
bericht te verwijderen. De staat aanvaardt geen aansprakelijkheid voor
schade, van welke aard ook, die verband houdt met risico's verbonden aan
het elektronisch verzenden van berichten.

This message may contain information that is not intended for you. If
you are not the addressee or if this message was sent to you by mistake,
you are requested to inform the sender and delete the message. The state
accepts no liability for damage of any kind resulting from the risks
inherent in the electronic transmission of messages.

More information about the mrtg mailing list