[mrtg] Problems with LoadMIBs

Schlageter Benjamin B.Schlageter at ebm.ch
Wed Jun 27 15:18:38 CEST 2007

Hello everybody

I run here MRTG 2.15.2.

Now i want to monitor my Squid over the Squid own SNMP Port 3401 - on an old MRTG installation, it worked perfect! But now, it looks like MRTG doesn't load the MIB.

Here a sample piece of the cfg file:

WorkDir: /home/mrtg/squid
LoadMIBs: /usr/share/snmp/mibs/SQUID-MIB.txt

Target[cacheServerRequests]: cacheServerRequests&cacheServerRequests:EBM2Net4 at proxy.ebmnet.ch:3401
MaxBytes[cacheServerRequests]: 10000000
Title[cacheServerRequests]: Server Requests @ proxy.ebmnet.ch
Options[cacheServerRequests]: growright, nopercent
PageTop[cacheServerRequests]: <h2>Server Requests @ proxy.ebmnet.ch</h2>
YLegend[cacheServerRequests]: requests/sec
ShortLegend[cacheServerRequests]: req/s
LegendI[cacheServerRequests]: Requests&nbsp;
Legend1[cacheServerRequests]: Requests

If I run this cfg file, i get this error:

Unknown SNMP var cacheServerRequests
 at /usr/local/mrtg-2/bin/mrtg line 2150
Use of uninitialized value in concatenation (.) or string at /usr/local/mrtg-2/bin/mrtg line 2166.
Use of uninitialized value in concatenation (.) or string at /usr/local/mrtg-2/bin/mrtg line 2166.

If I run this from the commandline, with snmpget, it works perfect:

snmpget -m SQUID-MIB -c community -v2c squidserver:3401 cacheServerRequests
SQUID-MIB::cacheServerRequests = INTEGER: 78214

Does anybody know, how I can fix this problem? Ah yeah, i checkt more then two times, that the MIB File is under /usr/share/snmp/mibs and it has the correct rights.

Thank you

Benjamin Schlageter

More information about the mrtg mailing list