[mrtg] MRTG: A Few Questions

Anurag Bist anuragsb at hotmail.com
Wed May 23 22:16:47 CEST 2007

Thank you very much for your detailed reply. I really appreciate your time and effort. I put my queries on the list, only after I did some exhaustive (I dunno if I can say that) research. Yes, we have a Core switch 65xx running both CatOS and IOS and acting as VTP server and eight other distribution level switches (Cisco 45xx) running on CatOS. I tried including the options --ifref=name, --ifref=catname, --ifref=descr and ifdesc=descr. But the thing is, when I compile the *.cfg file and run the associated *.cgi file on the web server, it comes up with a page that says "Available Targets" and the e-mail addresses of the creators of MRTG. It does not show any graphs whatsoever. If I do not use these --ifref options for compiling the *.cfg file, I can see the graphs.
I am using MRTG-2.15.2, RRDTOOl-1.2.23 and Apache Web Server.
Thanks in advance for your answers.

Date: Wed, 23 May 2007 14:53:21 -0500From: mrpaular at gmail.comTo: anuragsb at hotmail.comSubject: Re: [mrtg] MRTG: A Few QuestionsCC: mrtg at lists.oetiker.chOn 5/23/07, Anurag Bist <anuragsb at hotmail.com> wrote:

 1. I would like the cfg file, which is generated through the cfgmaker utility to give information on switch ports. Like it should tell whether a port on a particular switch is Gig1/1, Fa2/3 or Fa5/4 etc.
I'm going to make an assumption that you're running a Cisco Catalyst switch with somewhat current IOS.  If that's the case try passing "--ifdesc=catname" at the cfgmaker command line.  There is *alot* of other good stuff at http://oss.oetiker.ch/mrtg/doc/cfgmaker.en.html 

2.  I would like to have the feature that enables me to move my cursor over the traffic graph and shows a vertical bar that tells you how much data traveled through a device at a particular time.
The graph is nothing more than a PNG or GIF image file.  If you would like that functionality you'll need to look at something else to do that than MRTG out of the box.  

3. I downloaded a perl script called 'Cammer.pl' that scans the ports of switch or a router and gives you the information about the port mac address and the machine which is connected to that particular port. I tried running it, but I am always landing up with this error:  $> perl cammer.pl <snmp_community>@router.id  Can't locate SNMP_Session.pm in @INC (@INC contains: //../lib/mrtg2 / /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at cammer.pl line 44.BEGIN failed--compilation aborted at cammer.pl line 44 $> locate SNMP_Session.pm /usr/bin/SNMP_Session.pm/usr/lib/mrtg2/SNMP_Session.pm/usr/local/src/mrtg/lib/mrtg2/SNMP_Session.pm/usr/local/mrtg-2/lib/mrtg2/SNMP_Session.pm How can I overcome this problem?
SNMP::Session isn't in perl's path.  You can either update the script to include the full path or reinstall SNMP::Session.Paul
Change is good. See what’s different about Windows Live Hotmail. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20070523/0f7a8afc/attachment.html 

More information about the mrtg mailing list