[mrtg] MRTG reporting incorrect results

Patrick Kremer patrick at nicsys.net
Mon Nov 5 17:45:18 CET 2007

They are layer 3 Dell power connect 5324 switches. All 3 have 2 uplinks plugged into 2 cisco PIXs in failover mode. The one in question has ports split up into separate VLANS. 

The thing is MRTG was working just fine until about 3 weeks ago when the behavior started. No config changes to the switch or the MRTG file, I even restored from backup just to be sure.

Since MRTG seems to working on the other switches, the traffic must be legitimate somehow. 

-----Original Message-----
From: "Cook, Garry" <Garry.Cook at arcadis-us.com>
To: "Patrick Kremer" <patrick at nicsys.net>; "Mersberger, Robert" <robert.mersberger at goldenven.com>; "mrtg at lists.oetiker.ch" <mrtg at lists.oetiker.ch>
Sent: 11/5/07 9:01 AM
Subject: RE: [mrtg] MRTG reporting incorrect results

Have you mentioned what type of switch this is? Also, what is its function? Layer 3 or layer 2 switch? Give up some details Man...

While I wouldn't have arrived at the bad hardware conclusion, I don't think there is anything 'wrong' with your MRTG installation, so this may still be OT. However, the saving grace could be in the details of your switch config. I haven't done any L3 switching in a while, but I remember from a few years back that I had similar issues when attempting to graph this type of data with MRTG.


This apparently started happening 2 weeks ago. All MRTG-monitored interfaces on one particular switch are showing identical graphs for all "Out" bandwidth. As expected, the report shows varying values for "In" Max/Average/Current for each port on the switch. However, each port has the exact same values for all "Out" Max/Average/Current. The blue line is exactly the same for all ports on all graphs beginning between at about week 41 1/2.  Obviously, this isn't possible

It doesn't appear to be something specifically wrong with MRTG itself because the rest of the monitored switches seem to be reporting correctly. The MRTG config for the switch in question hasn't changed in 3 months. I have already tried rebooting the switch and the machine hosting MRTG. Because I couldn't think of anything else to do, I tried regenerating the configuration file with an snmpwalk, but it's no different from the original config file

More information about the mrtg mailing list