[mrtg] Problem Compiling MRTG

Joel Roberts Joel.Roberts at pinkardcc.com
Tue Sep 25 01:31:35 CEST 2007

Using the Debian Package worked great! Thanks for the advice.

Heads up to any others having the same problem though, the apt-get
install mrtg didn't work for me, just said the package was unavailable.
Going through Synaptic package manager was more step-by-step in showing
which dependencies needed to be installed before the mrtg installation
would complete.

-----Original Message-----
From: mrtg-bounces at lists.oetiker.ch
[mailto:mrtg-bounces at lists.oetiker.ch] On Behalf Of Luis Carlos Solano
Sent: Monday, September 24, 2007 1:40 PM
To: mrtg at lists.oetiker.ch
Subject: Re: [mrtg] Problem Compiling MRTG

Joel Roberts wrote:
> I'm going through the Unix installation instructions located at 
> http://oss.oetiker.ch/mrtg/doc/mrtg-unix-guide.en.html for an 
> installation on a Debian Linux box. Everything works fine until I get 
> to the step for MRTG Compilation. When I run the ./configure command, 
> I get the following:
> lwsyslog2:/usr/local/src/mrtg-2.15.2# ./configure 
> --prefix=/usr/local/mrtg-2.15.2 --with-gd=/usr/local/src/gd 
> --with-z=/usr/local/src/zlib --with-png=/usr/local/src/libpng

as I do not use Debian, I do not know if those parameters are specific 
for your system, therefore, you need to compile mrtg manually.
If not, there are Debian packages for MRTG, I recommend you to use them.

(apt-get install mrtg)

Luis Carlos.

mrtg mailing list
mrtg at lists.oetiker.ch

More information about the mrtg mailing list