[mrtg] Can't create cfg file on Windows Server 2008

Alex Carlock oetiker at alexcarlock.com
Thu Aug 14 05:29:48 CEST 2008

Hello all,

I'm trying to setup MRTG 2.16.2 on Windows Server 2008, but I've run into a problem.  I have ActivePerl- installed and running perl mrtg generates the expected "Usage: mrtg <config-file>" message.  So I think things are installed properly.

Unfortunately I can't generate the config file.  When I run "perl cfgmaker public at --global "WorkDir: C:\mrtg-2.16.2\data" --output mrtg.cfg" I get the following error message:
SNMP Error:
no response received
SNMPv1_Session (remote host: "" [].161)
                  community: "public"
                 request ID: -1478975803
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
 at C:/mrtg-2.16.2/bin\..\lib\mrtg2/SNMP_util.pm line 629
SNMPWALK Problem for on public at
 at cfgmaker line 950
WARNING: Skipping public at as no info could be retrieved

I know that the IP and community are correct because I have MRTG 2.15.1 running on a Windows Server 2003 machine with these settings.

I have User Account Control turned off on this server, and I've even tried running it from an elevated command prompt (right click then Run as Administrator) just in case, but that didn't make a difference.  Also, the Windows Firewall is turned off.

Does anyone have any thoughts?


More information about the mrtg mailing list