[mrtg] Temerature reading on netapp 2020

Steve Shipway s.shipway at auckland.ac.nz
Sun Jul 27 23:49:37 CEST 2008

> I can't still get it working.
> I have talk to netapp and the don't have separate OID´s for the
> temperature.

OK, I can see what's gone wrong here (now that I can see the logs).

> 2008-07-25 12:16:31: ERROR: Target[netapptempone][_IN_]
> 'encTempSensorsCurrentTemp.1& encTempSensorsCurrentTemp. $target-
> >[0]{$mode} ' (eval): Bareword "encTempSensorsCurrentTemp" not allowed
> while "strict subs" in use at (eval 17) line 1.
> Bareword "encTempSensorsCurrentTemp" not allowed while "strict subs" in
> use at (eval 17) line 1.

This means that it does not recognise ' encTempSensorsCurrentTemp'

Since this is your SNMP symbolic ID, it follows that your MIB is not loading or parsing correctly.

> LoadMIBS: /etc/mrtg/mibs/netapp.mib

Now, you have this, but maybe you need some more supporting MIBs on top of it.  I would suggest that instead of using

> Target[netappTempOne]:encTempSensorsCurrentTemp.1&
> encTempSensorsCurrentTemp.1:public at|netappTempone

You instead set the OIDs explicitly numerically, avoiding this problem entirely.  Since I don't have the MIB I cant give you the exact numerical OID to use, but I'm sure you can work it out.

> when I run mrtg whit debug=tarp,snpo,log I get this information
> root at mrtg:/etc/mrtg/test# env LANG=C /usr/bin/mrtg
> /etc/mrtg/test/netapp.cfg --debug=tarp,snpo,log
> --tarp: Starting netapptempone -> encTempSensorsCurrentTemp.1&
> encTempSensorsCurrentTemp.1:public at|netappTempone
> --tarp: &targparser external done: 'encTempSensorsCurrentTemp.1&
> encTempSensorsCurrentTemp.1:public at|netappTempone'
> --tarp: &targparser complex done: 'encTempSensorsCurrentTemp.1&
> encTempSensorsCurrentTemp.1:public at|netappTempone'
> --tarp: New simple target [0] '1:public at|netappTempone':

You can see here that the symbol is not expanded and it reduces to interface 1...


More information about the mrtg mailing list