[mrtg] bytes v/s bits

Georges Touma georges.touma at navlink.com
Tue Oct 28 07:55:49 CET 2008

Thank you all for the quick replies,

Please find below some more details about this subject:

We are using MRTG with RRD and we have a script developed in-house to graph
the data from the RRD dbs.
I dumped the RRD data in a xml file and the values in the DB and the graph
are matching and therefore it seems that mrtg is dumping the data in the RRD
in bytes regardless of the option set globally or set on the target itself.
I tried to use 64bit counters but also with the same result.

It would be really great if someone can shed a light on the below questions:

1-Is it confirmed that MRTG dumps the numbers in bytes in the RRDDB?
2-If so, should the front-end (in my case the graphing script) do the
3-If not and MRTG can store the data in the RRDDB in bits, what more can I
test/change in my cfg file? 

-Output from router interface
  30 second input rate 10315000 bits/sec, 1005 packets/sec
  30 second output rate 10315000 bits/sec, 1005 packets/sec

-Attached graph shows 1.2M 

-mrtg.cfg relevant section below:

EnableIPv6: no
WorkDir: /rrddbs/
Options[_]: bits,growright
RunAsDaemon: Yes
LogFormat: rrdtool
PathAdd: /data/rrdtool-1.2.19/bin
LibAdd: /data/rrdtool-1.2.19/lib/perl
Forks: 4

##### Customer: mytools
## x.x.x.x- Interface 3

Target[mytools_my-router-1_3.interfacegigabitethernet0-0]: at 10.255.12
MaxBytes[mytools_my-router-1_3.interfacegigabitethernet0-0]: 12500000
Title[mytools_my-router-1_3.interfacegigabitethernet0-0]: Traffic Analysis
for mytools x.x.x.x 3
Options[mytools_my-router-1_3.interfacegigabitethernet0-0]: bits,growright

Many thanks,
Georges Touma 
System and Network Specialist

-----Original Message-----
From: mrtg-bounces at lists.oetiker.ch [mailto:mrtg-bounces at lists.oetiker.ch]
On Behalf Of McDonald, Dan
Sent: Monday, October 27, 2008 8:04 PM
To: mrtg at lists.oetiker.ch
Subject: Re: [mrtg] bytes v/s bits

On Mon, 2008-10-27 at 17:31 +0100, Alex van den Bogaerdt wrote:
> ----- Original Message -----
> From: "Georges Touma" <georges.touma at navlink.com>
> To: "'Anson Rinesmith'" <arinesmith at bigrivertelephone.com>;
> <mrtg at lists.oetiker.ch>

> > Apologies for the confusion:
> >
> > It is showing bytes instead of bits although I have the bits option set.
> Options[_]: ...
> is only a default.  This setting is used if there is no other Option 
> statement more specific to the target.

And more than that, it is only default for Target(s)[]: following the
Options[_]: statement.

> Try Options[mytools_my-router-1_3.interfacegigabitethernet0-0]: 
> bits,growright

> Or find the line currently specifying options for your target, and 
> remove it.
> You cannot have both.

You can, with Options[^]:

> And Dan MacDonald's question may also be very important... you can set 
> all the options you want but if the front-end doesn't use them...

I'm trying to remember if the stored value in the rrdfile is in bits, or
if it is always bytes and the display always does the multiplication.
Seems like sometimes you need to re-create the rrd/logfile when you
change the options.

Daniel J McDonald, CCIE #2495, CISSP #78281, CNX
Austin Energy

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Outputs.png
Type: image/png
Size: 9781 bytes
Desc: not available
Url : http://lists.oetiker.ch/pipermail/mrtg/attachments/20081028/cc9f0da5/attachment.png 

More information about the mrtg mailing list