[mrtg] MRTG Stopped Populating CPU Graphs on CentOS

Matt Baer matt at baerconsult.com
Sat Feb 27 00:43:18 CET 2010

I recently migrated my mail server over to a new physical machine. Same OS (CentOS 5.4), same exact SNMP file, everything appears to be the sameo. Oddly enough, I didn't have to update anything at all with MRTG, which surprised me, but hey, it's a good thing. The only thing that isn't working is graphing the CPU usage. No matter what, it's not working, it displays a flat line. I've tried adding gauge, removing gauge, completely removing the entry in the .cfg file and adding it under a different name, graphed 1 core instead of 2 cores per graph, using OIDs, none of that has worked. It works when I use the OID with snmpwalk, they return values but still nothing on the graphs. 

I've check the logs and I get unknown SNMP var for cores 1 & 2, but the very same variable is used for cores 3 & 4 with the last octet changed of course. There is no other mention of this particular entry in the logs at all, yet it's still flat line. I have about a dozen other graphs working just fine on the exact same machine, but graphing the CPU will not work for some reason. I've restarted every service on both machines, it doesn't matter, it will not graph. Any ideas at all are welcome. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20100226/49d41fd7/attachment.htm 

More information about the mrtg mailing list