[mrtg] gvolk's interface-errors.template not working now...

Arvon Griffiths Arvon.Griffiths at txdot.gov
Tue Nov 9 23:20:52 CET 2010

Nope, dos2unix didn't work...   same error.

>>> Steve Shipway <s.shipway at auckland.ac.nz> 11/9/2010 4:15 PM >>>
 Sounds like your template file is corrupt.

Check the template file to see if there is a trailing ^M or space on the ECHO lines -- possibly it has been messed up by Windows and has the \n at the end of the lines changed to \r\n?  Try running dos2unix on the template file which should fix it.


Steve Shipway
University of Auckland ITS
UNIX Systems Design Lead
s.shipway at auckland.ac.nz
Ph: +64 9 373 7599 ext 86487
From: mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch [mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch] on behalf of Arvon Griffiths [Arvon.Griffiths at txdot.gov]
Sent: Wednesday, 10 November 2010 10:36 a.m.
To: mrtg
Subject: [mrtg] gvolk's interface-errors.template not working now...

When I run my script:
    cfgmaker --global "WorkDir:$workdir/" --global "LogFormat: rrdtool" --if-template=interface-errors.template '--if-filter=$default && ($if_type==30 || $if_type==32)'  --output $cfgdir/$router-err.cfg public@$router:::::2
I get:
    Evaluation of the contents in the file
    gave the error
    "Can't find string terminator "
    ECHO" anywhere before EOF at (eval 13) line 26, <IF_TEMPLATE> line 65.
    Exiting cfgmaker

Texas Transportation Forum

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20101109/03d67a6d/attachment.htm 

More information about the mrtg mailing list