[mrtg] MRTG not honouring mib file

Babu C babscontact at rediffmail.com
Sat Oct 9 08:20:37 CEST 2010

just to add to my previous mail,
I have tried to downgrade mrtg version to check, did install mrtg 
2.16.2 and tried to run and its showing the same errors. So now I am 
concluding nothing wrong with mrtg but suspecting the net-snmp port of 


On Sat, 09 Oct 2010 01:44:29 +0530  wrote

I added three print statements to the "snmpMIB_to_OID" function in 

On line 1197, change

 print "snmpMIB_to_OID: opening $arg\n" if ($arg =~ /squid/i);


 print "snmpMIB_to_OID: opening $arg\n";

and copy the new version to the




locations and try running mrtg again. It should print out any MIB file 
it tries to load.

Do you have multiple 'LoadMibs:' directives in your configuration? It's 
possible mrtg is only using the last one. If you have multiple MIB 
files to load you can list them all on one line, separated by a comma.

Mike Mitchell

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20101009/a39d7ad3/attachment.htm 

More information about the mrtg mailing list