[mrtg] Issue configuring MRTG

Lyle Giese lyle at lcrcomputer.net
Thu Apr 28 02:39:55 CEST 2011

You do realize that .png files are portable network graphic files(like 
.jpg or .gif)?

Have you tried to read any of the docs available for MRTG?

Try this:



On 04/27/11 09:18, Anand, Sakshi wrote:
> I ran ldconfig and I reinstalled everything on a different server. Now, when I run following command -
> ./configure --prefix=/usr/local/mrtg-2
> The final output is -
>     Support for PNG library:          yes
>     Support for JPEG library:         yes
>     Support for Freetype 2.x library: yes
>     Support for Fontconfig library:   yes
>     Support for Xpm library:          yes
>     Support for pthreads:             yes
> configure: creating ./config.status
> config.status: creating Makefile
> config.status: creating config/Makefile
> config.status: creating config/gdlib-config
> config.status: creating test/Makefile
> config.status: creating config.h
> config.status: executing depfiles commands
> Then, 'make' and 'make install' also do not give any error.
> After this, I could configure and run it fine without any exception. But, I don't know what to do next. The only files I can see in my working directory are - mrtg-r.png, mrtg-l.png and mrtg-m.png which are not in human readable form.
> I am not even able to locate the log file. Please help and share a sample mrtg.conf file too.
> Thanks&  Regards,
> Sakshi Anand
> -----Original Message-----
> From: mrtg-bounces+sa185043=ncr.com at lists.oetiker.ch [mailto:mrtg-bounces+sa185043=ncr.com at lists.oetiker.ch] On Behalf Of Lyle Giese
> Sent: Monday, April 25, 2011 6:56 PM
> To: mrtg at lists.oetiker.ch
> Subject: Re: [mrtg] Issue configuring MRTG
> Another thing is to just run ldconfig as root and try again.  Not knowing what linux distro or how he installed these packages...
> Lyle Giese
> LCR Computer Services, Inc.
> On 04/25/11 07:36, Steve Shipway wrote:
>> Looks to me as if your GD library was not compiled with PNG support
>> (and maybe not JPG or GIF support either). Where did you get your GD
>> library from? Might be time to upgrade or reinstall.
>> Steve
>> *Steve Shipway*
>> University of Auckland ITS
>> /UNIX Systems Design Lead/
>> s.shipway at auckland.ac.nz<mailto:s.shipway at auckland.ac.nz>
>> Ph: +64 9 373 7599 ext 86487
>> //
>> ----------------------------------------------------------------------
>> --
>> *From:* mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch
>> [mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch] on behalf of
>> Anand, Sakshi [sa185043 at ncr.com]
>> *Sent:* Monday, 25 April 2011 7:31 p.m.
>> *To:* mrtg at lists.oetiker.ch
>> *Subject:* [mrtg] Issue configuring MRTG
>> All,
>> I am getting following error when configuring MRTG. I want to use it
>> to measure bandwidth using Nagios.
>> checking for gdImageGif in -lgd... no
>> checking for gdImagePng in -lgd... no
>> checking for gdImagePng_jpg in -lgd... no checking for
>> gdImagePng_jpg_ft in -lgd... no checking gd.h usability... yes
>> checking gd.h presence... yes checking for gd.h... yes
>> ** Ooops, one of many bad things happened:
>> a) You don't have the GD library installed. Get it from
>> _http://www.boutell.com_, compile it and use either --with-gd-lib=DIR
>> and --with-gd-inc=DIR to specify its location. You might also have to
>> use --with-z-inc, --with-z-lib and --with-png-inc, --with-png-lib for
>> gd versions 1.6 and higher. Check config.log for more information on
>> the problem.
>> b) You have the GD library installed, but not the gd.h header file.
>> Download the source (see above) and use --with-gd-inc=DIR to specify
>> where the file can be found.
>> c) You have the library and the header file installed, but you also
>> have a shared GD library in the same directory. Remove the shared
>> library files and/or links (e.g. libgd.so.2.0.0, libgd.so and
>> libgd.so.2). This is especially likely if you're using a recent (post
>> 1.8.4) version of GD and didn't configure it with --disable-shared.
>> d) You have gd library installed and also it's headers, but you are
>> missing libpng (and headers) or freetype (and headers) (mrtg does not
>> use freetype, but if your copy of gd is precompiled against it, you
>> have to install it ... I have verified all the 3 points mentioned above
>> but everything seems to be in place.
>> Please help.
>> Thanks&  Regards,
>> Sakshi Anand
>> _______________________________________________
>> mrtg mailing list
>> mrtg at lists.oetiker.ch
>> https://lists.oetiker.ch/cgi-bin/listinfo/mrtg
> _______________________________________________
> mrtg mailing list
> mrtg at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/mrtg

More information about the mrtg mailing list