[mrtg] Error msg re Failure to resolve host name in snmp: RESOLVED

Mabry Tyson Tyson at AI.SRI.COM
Sat Jan 22 01:32:12 CET 2011

I've tracked down the problem, at least as far as what triggered it.

Our nsswitch.conf directs that name resolution should be done by 
consulting the /etc/hosts first.
If that file has 22 instances of the name (ie, 22 different addresses), 
then we get the error.  If I delete any one (ok, I only tried 5 
different lines) so there are 21 instances of the name, then I don't get 
the error.  If I change nsswitch.conf to use DNS first (which has 22 
different addresses) then I don't get the error.

To me, that sounds like an OS problem in the resolver.  In any case, it 
isn't a mrtg issue.

(I did confirm that it worked the last time we ran 2.14.7 and failed the 
first time we ran 2.15.  But I found that it was now failing if I tried 
running it with 2.14.7.   At about the same time as I updated mrtg, I 
also updated our /etc/hosts to accurately reflect the addresses the 
router has.)

More information about the mrtg mailing list