[mrtg] aescfb128 support for privProtocol with SNMPv3

vipinb check.crazy at gmail.com
Wed May 25 23:51:57 CEST 2011

Solved at last..

There was a error in USM module of NET::SNMP on windows that was not
matching aescfb128 to PRIV_PROTOCOL_AESCFB128

In File USM.pm in NET/SNMP/SECURITY  the regex used was 

  '(?:(?:cfb)?128-?)?aes(?:-?128)?',        PRIV_PROTOCOL_AESCFB128,

The Regex would only match to  "cfb128aes128" as supplied privProtocol.
It would not match to any of aes128cfb, aescfb128 or cfbaes128.
MRTG doc suggests  privprotocol to be 
   privprotocol {des|3desede|aescfb128|aescfb192|aescfb256}
None of AES  would match it.

When I passed cfb128aes128 to privprotocol it worked like charm.

My NET::SNMP USM.pm  version is 
 $Id: USM.pm,v 4.1 2010/09/10 00:01:22 dtown Rel $

Either mrtg documentation has to be changed or the CPAN net:snmp should
rectify their regex

View this message in context: http://mrtg-mailinglists.795376.n2.nabble.com/aescfb128-support-for-privProtocol-with-SNMPv3-tp6396611p6404662.html
Sent from the MRTG Users Mailinglist mailing list archive at Nabble.com.

More information about the mrtg mailing list