[mrtg] Another MRTG SNMPv3 problem

Rich K richk01 at gmail.com
Wed Nov 30 09:13:01 CET 2011

Installed programs versions: MRTG 2.17.2 & ActivePerl-

I'm trying to get MRTG using SNMPv3 running under Windows 7. I have
successfully used it with SNMPv1 but need to make the change to v3. I have
combed the message board to see what I'm doing wrong but haven't found
anything. I have successfully installed:

NET::SNMP v(6.01)
Crypt::DES v(2.05)
Digest::MD5 v(2.51)
Digest::SHA1 v(2.13)
Digest::SHA v(5.63)
Digest::HMAC v(1.03)
Crypt::Rijndael v(1.09)

I tested NET::SNMP with <perl -e "use Net::SNMP"> and just a prompt back.
I've used the command <perl -MCPAN -e "install Crypt::DES">, etc to verify
I have the latest versions of all non-core modules.

When I run cfgmaker with the following parameters:

perl cfgmaker --enablesnmpv3 --username=<username> --authprotocol=sha
--authpassword=<passwd> --privprotocol=aescfb128 --privpassword=<passwd>
--contextengineid=8000000903002893FE999B81 --snmp-options=:::::3 <switch IP>

I get the error:
    cfgmaker [options] [community@]router [[options] [community@]router ...]

<removed for brevity>

'--privprotocol' is not recognized as an internal or external command,
operable program or batch file.

I have tried using each of these cfb128aes, cfb128aes128, aescfb128 for
--privprotocol but get the same error every time. I have looked at the
USM.pm and it looks like aescfb128 is the correct one.

My username contains numbers, letters and the "!" My passwords contain
numbers, letters "!" and "&" for characters, could those be causing the

Any suggestions? Comments? Nasty Remarks? Thanks for your time.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20111130/69cdc482/attachment.htm 

More information about the mrtg mailing list