[mrtg] Strange error when trying to use snmp v3

Ed LaFrance edl at connexinternet.com
Fri Aug 17 21:13:20 CEST 2012

Hello All -

I have mrtg 2.15.0 with Net:SNMP installed. I've set up my target device 
and I can successfully do an snmpwalk of it with this command:

snmpwalk -u public2 -v 3 -e 80003a8c0431323334 -a MD5 -A xxxxxxxx -l 
authPriv -x DES -X yyyyyyyy -engineid=nnnnnnnnnnnnnn 
--snmp-options=:::::3 user at router_ip

But when I try to run cfgmaker with this command:

/usr/local/mrtg-2/bin/cfgmaker --global 'Workdir:/path/to/workdir' 
--global 'Options[_]: bits, growright' --ifref=descr --output 
/path/to/output.cfg --enablesnmpv3 --username=username 
--authprotocol=MD5 --authpassword=password --privprotocol=des 
--privpassword=password --contextengineid=nnnnnnnnnnnnnn 
--snmp-options=:::::3 user at router_ip

I get this error:

--base: SNMP V3 libraries found, SNMP V3 enabled.
--base: Get Device Info on user at router_ip:::::3
SNMPopen failed: Expected OBJECT IDENTIFIER, but found SEQUENCE

during discovery at /usr/local/mrtg-2/bin/cfgmaker line 915
SNMPWALK Problem for user at router_ip:::::3:v4only
  at /usr/local/mrtg-2/bin/cfgmaker line 915
WARNING: Skipping user at router_ip:::::3 as no info could be retrieved

I've tried it without the privprotocol and privpassword and gotten the 
same result. Searching for that error comes up empty. Any ideas?


(800) 362-7579 ext 1

+ Colocation    Dedicated Servers   IPv4 & IPv6 Transit +
Connex Internet Services, Inc.     direct: (916) 265-1568
11230 Gold Express Dr #310-313        fax: (916) 880-5663
Gold River, CA 95670            http://connexinternet.com

More information about the mrtg mailing list