[mrtg] Fwd: MRTG& SNMPv3

Tom Smyth tom.smyth at wirelessconnect.eu
Wed Apr 24 02:47:19 CEST 2013

Hi Lads,

I was wondering if someone could help me, I have a query about how to get
Cfgmaker and MRTG to talk SNMPv3

with Privacy and Authentication enabled, to a Router.

I can snmp walk the router  fine...  I just cant get mrtg + snmpv3

I know it may not be straight forward but Im looking for a fully worked
snmp example... I am willing to pay someone for this so you can contact me
on my email regarding this...  or if you dont want to be paid more money I
will Dontate more money to the project...

I currently have the following packages installed  on a Centos 6.4 i386 box



My router SNMP v3 config
/snmp community
set [ find default=yes ]
encryption-password=testtest name=Read_Only security=private
set contact=support at wirelessconnect.eu enabled=yes trap-community=
    Read_Only trap-target= trap-version=3

What Im looking for is a working example of
MRTG Cfgmaker commnand that would successfully connect to a router with the
configuration above with Auth and Priv enabled for a given context ID ...
on SNMPv3

If you have to do something funky with context ID ...? for example

I get weird unrecognised ASN.1 errors  from the Cfgmaker script with
hexidecimal references that change every time I modify the cfgmaker command.

I have tried many things and I just want some one . give me assistance to
get the Cfgmaker command working...

I can snmp walk the router  fine...  I just cant get mrtg + snmpv3

Below ... is some mails with more information

On Mon, Apr 22, 2013 at 7:29 AM, Tom Smyth <tom.smyth at wirelessconnect.eu>wrote:

> Hi lads,
> Does any one have tips here for me I just dont get how to get around the
> Context ID,
> I can snmpwalk no problem without the context ID.. (which is not set on
> the router as it is optional)
> But everytime I set it on the router and I set it on the command
> on Mrtg Server I set the following command
>  cfgmaker --enablesnmpv3 --contextengineid "" --username=Read_Only
> --authpassword=testtest --authprotocol=sha --privpassword=testtest
> --privprotocol=des --ifref=ip --community=Read_Only
> I get this error on the router
> 07:21:39 snmp,debug v3 err: 3 unknown engine id
> 07:21:39 snmp packet from: version: 3
> 07:21:39 snmp user: Read_Only_Secure
> 07:21:39 snmp,debug v3 err: 1 not in time window or incorrect engine boots
> 07:21:39 snmp packet from: version: 3
> 07:21:39 snmp user: Read_Only_Secure
> 07:21:39 snmp,debug getnextgetbulk . reps:c nonreps:0
> Any Help or advice would be appreciated
> On Thu, Jan 24, 2013 at 11:00 PM, Tom Smyth <tom.smyth at wirelessconnect.eu>wrote:
>> Hi lads,
>> Does anyone have any tips for running MRTG and SNMPv3  (with Auth and
>> Priv) SHA & DES
>> I have been having issues with Cfgmaker not accepting my command without
>> mandatory   Context ID  (even tho context ID is Optional)
>> I have tried commenting out the Die if Context is not set lines in
>> cfgmaker
>> I have been able to SNMP walk with SNmp tools and I have been able to
>> communicate with routers with Cacti...
>> but no matter what I try I cant get MRTG cfgmaker to work....with SNMPv3
>> I have tried with v2.17.4 and with the standard mrtg package on Centos 6.2
>> if anyone can help me with this...
>> anything at all ... even a sample manual mrtg.cfg file for snmpv3 would
>> be cool
>> Thanks for your time
>> --
>> Kindest regards,
>> Tom Smyth
>> Mobile: +353 87 6193172
>> ---------------------------------
>> This email contains information which may be confidential or privileged.
>> The information is intended solely for the use of the individual or entity
>> named above.  If you are not the intended recipient, be aware that
>> any disclosure, copying, distribution or use of the contents of this
>> information is prohibited. If you have received this electronic
>> transmission in error, please notify me by telephone or by electronic mail
>> immediately. Any opinions expressed are those of the author, not the
>> company's  .This email does not constitute either offer or acceptance of
>> any contractually binding agreement. Such offer or acceptance must be
>> communicated in
>> writing. You are requested to carry out your own virus check before
>> opening any attachment. Thomas Smyth accepts no liability for any loss or
>> damage which may be caused by malicious software or attachments.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20130424/49d4de42/attachment.htm 

More information about the mrtg mailing list