[rrd-developers] Re: calling rrd_create directly in librrd.so

Chris Carton u43o1 at unb.ca
Fri Jul 20 20:16:11 MEST 2001

Have you tried linking statically with librrd.a instead of librrd.so? Might be 
worth a shot. I'm using librrd.a.

>===== Original Message From Ashok <amandala at speedtrak.com> =====
>This happens with the first rrd_xxx call itself. I made sure that optind and 
>were set to zero before making this call, but it still doesn't work. The 
>solution I implemented was to fork a  rrdtool process with "-" argument (so 
that it
>will not exit after each command, but waits for the next command) and write 
to the
>stdin of this process through a pipe from my application process. This works, 
>it is difficult to determine if there were any errors unless I read the 
stdout and
>search for the "ERROR" string.
>The solution with calling "rrd_xxx" functions within the librrd.so would be 
nice if
>it worked. The interesting thing is calling rrd_fetch_fn() directly(instead 
>rrd_fetch())  works. (which again raises the suspicion on the getopt_long() 

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list