[rrd-developers] Problem compiling under FreeBSD

Stanislav Sinyagin ssinyagin at yahoo.com
Tue Feb 24 21:57:47 MET 2004


I tried to compile the current snapshot under FreeBSD 5.1
(the problem applies to 4.9 too). 
First it was rather tricky to build the configure options. 
This worked:

./configure CPPFLAGS="-I/opt/sources/cgilib-0.5 \
-I/usr/local/include/libart-2.0 \
-I/usr/local/include \
-I/usr/local/include/freetype2" \
LDFLAGS="-L/opt/sources/cgilib-0.5 -L/usr/local/lib"

The next problem requires some tweaking in src/Makefile.am, 
probably some OS-specific libraries need to be specified in configure.ac.

Linker failed (output follows) to find the library for "-lpthread". 
Manual says threads don't need any additional library, and GCC should be executed with 
the flag "-pthread".


root at vmlab#make
make  all-recursive
Making all in src
/usr/local/bin/bash ../libtool --mode=link gcc  -g -O2 -Wall -pedantic -Wshadow -Wpointer-arith
-Wcast-align -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -W  -fPIC -DPIC
  -L/opt/sources/cgilib-0.5 -L/usr/local/lib -o librrd_th.la -rpath /usr/local/rrdtool-1.1.0/lib
-version-info 1:2:0 getopt.lo getopt1.lo parsetime.lo hash_32.lo rrd_hw.lo  pngsize.lo
rrd_create.lo rrd_diff.lo rrd_dump.lo rrd_info.lo  rrd_error.lo rrd_fetch.lo rrd_format.lo
rrd_graph.lo  rrd_graph_helper.lo rrd_last.lo rrd_open.lo rrd_resize.lo  rrd_restore.lo
rrd_rpncalc.lo rrd_tune.lo rrd_update.lo  rrd_xport.lo rrd_nan_inf.lo rrd_gfx.lo rrd_afm.lo 
rrd_afm_data.lo rrd_tool.lo rrd_thread_safe.lo -lpthread -lfreetype -lpng -lz -lart_lgpl_2 -lcgi
gcc -shared  .libs/getopt.o .libs/getopt1.o .libs/parsetime.o .libs/hash_32.o .libs/rrd_hw.o
.libs/pngsize.o .libs/rrd_create.o .libs/rrd_diff.o .libs/rrd_dump.o .libs/rrd_info.o
.libs/rrd_error.o .libs/rrd_fetch.o .libs/rrd_format.o .libs/rrd_graph.o .libs/rrd_graph_helper.o
.libs/rrd_last.o .libs/rrd_open.o .libs/rrd_resize.o .libs/rrd_restore.o .libs/rrd_rpncalc.o
.libs/rrd_tune.o .libs/rrd_update.o .libs/rrd_xport.o .libs/rrd_nan_inf.o .libs/rrd_gfx.o
.libs/rrd_afm.o .libs/rrd_afm_data.o .libs/rrd_tool.o .libs/rrd_thread_safe.o 
-L/opt/sources/cgilib-0.5 -L/usr/local/lib -lpthread -lfreetype -lpng -lz -lart_lgpl_2 -lcgi -lm 
-Wl,-soname -Wl,librrd_th.so.1 -o .libs/librrd_th.so.1
/usr/bin/ld: cannot find -lpthread
*** Error code 1

Stop in /usr/opt/sources/rrdtool-2004-02-24/src.
*** Error code 1

Stop in /usr/opt/sources/rrdtool-2004-02-24.
*** Error code 1

Stop in /usr/opt/sources/rrdtool-2004-02-24.

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/rrd-developers
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the rrd-developers mailing list