[rrd-developers] cgilib-0.5.1.tar.gz

D. Walsh info at daleenterprise.com
Sat Nov 5 20:14:28 MET 2005

I understand this library is required and with all of the trouble  
required to install it I figured something should be done about it  
becuase it hasn't been worked on since 08/1999.
I took a few moments and fixed it, I've tested under Linux, Darwin,  
Mac OSX and it builds without any issues.

I've fixed the malloc.h issue, the problem with the cgitest.c and   
jumpto.c not compiling and an issue with string.h and have also built  
using gcc 4.0 without issue.

I've also added the ability to generate a shared library if you want  
one and the cgi-bin directory is definable during configure so you  
can point it to your favorite location.

To assist everyone one requiring cgilib in building rrdtool, IMHO it  
would be wise to place this in the rrdtool archives and amend the  
documentation to download and use this archive instead of the older  
cgilib-0.5.tar.gz archive.

I've attached it and hopefully it's not stripped off because upload  
access isn't available at the rrdtool site.

-- Dale

-- Attached file removed by Ecartis and put at URL below --
-- Type: application/x-gzip
-- Size: 296k (303116 bytes)
-- URL : http://lists.ee.ethz.ch/p/cgilib-0.5.1.tar.gz

-- Binary/unsupported file stripped by Ecartis --
-- Err : No filename to use for decode, file stripped.
-- Type: text/plain

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-developers
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-developers mailing list