[rrd-developers] rrdtool 1.2.6

D. Walsh info at daleenterprise.com
Tue Sep 20 04:53:06 MEST 2005

I must say I am disappointed in the path this app has taken.

My disappointment stems from  the amount of work required to install  

If we examine 1.0.49, we see that all dependent software is included  
(like libcgi etc...) but the newer version are not this way.

After a short struggle to install darwinports just to install libcg  
and libart, I found that most of my apps that use librrd fail to  
compile because of changes in rrd_graph function API and other  

As well, I've noticed that the contrib directory is gone and that  
support for a php module has vanished making it even harder to upgrade.

After fixing the php extension to use the new rrd_graph API I found  
that rrd_graph isn't recognized as a valid library function.

Going further I wrote a test suite which tests for the rrd_graph  
function in the library and it fails to find it in 1.2.6 but has no  
problems with the 1.0.49 library.

All libraries that were tested were static  (librrd.a) type libraries.

Being annoyed at the way things were, I set out to fix the problems.

I started by repackaging the source to include libcgi-0.5 and  
libart-2.0 like it did in 1.0.49, this worked out very well as all is  
installed without having to obtain additional packages that may or  
may not have been ported.

While I can use rrdtool from the cli and from perl scripts, there is  
still a problem with librrd and the recognition of rrd_graph library  
functions so building with this library still doesn't work.

Any chance that you guys are going to correct these problems/issues  
in a release version?

-- Dale

Unsubscribe mailto:rrd-developers-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:rrd-developers-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/rrd-developers
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the rrd-developers mailing list