[rrd-developers] [patch] RFC: make rrdresise a bit more terse in syntax

Tobias Oetiker tobi at oetiker.ch
Thu Sep 18 15:38:25 CEST 2008

Hi Peter,

this syntax does not sit well with me, since - is reserved for
option names ...

how about just adding a


command which would provide that functionality you want to add with
= ?


Today Peter Volkov wrote:

> Hello.
> Some time ago Robin Johnson (robbat2 AT gentoo.org) wrote patch to make
> it possible to use a bit different but more comfortable syntax for
> rrdresize.
> rrdtool resize filename rra-num [+|-|=]rows
> So it's possible to avoid GROW or SHRINK in in command line and just
> write +rows. What do you think is rrdresize worth such change?
> Patch in attachment.
> With best regards,

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-developers mailing list