[rrd-developers] RRDtool + Lua module patch

Fidelis Assis fidelis at pobox.com
Tue Sep 23 02:03:09 CEST 2008

Hi Tobi,

Tobias Oetiker escreveu:
> Fidelis,
> thanks ... I have integrated the patch and tried to fix the prefix
> issues .... when I try to build on my hardy setup, it does not seem
> to work though ...
> a) lua does not get picked up for building automatically even
>    though I have lua and liblua-dev installed

Probably because of an old version - see below.

> b) when I run make lua in the bindings directory I get
> oetiker> make lua
> cd lua && /usr/bin/lua Makefile.lua "PREFIX=/usr/local/rrdtool-1.3.2 POD2MAN=/usr/bin/pod2man LUABIN=/usr/bin/lua LIB=/usr/local/rrdtool-1.3.2/lib/lua" > Makefile && make
> /usr/bin/lua: Makefile.lua:3: attempt to call field `match' (a nil value)

The 'match' function in string lib was introduced in Lua 5.1 - minimum
required for RRDLua -, so it seems you have 5.0 or older. And I have a
broken code to check Lua version... Sorry for that, I'll fix it and send
a patch.

BTW, is there a standard way to check version in autoconf?  I'm just
starting to play with autoconf.


More information about the rrd-developers mailing list