[rrd-developers] [PATCH] add 'flush' to language bindings

Sebastian Harl sh at tokkee.org
Fri Mar 27 15:56:12 CET 2009


On Fri, Mar 27, 2009 at 08:59:13AM -0500, kevin brintnall wrote:
> On Fri, Mar 27, 2009 at 01:37:53PM +0100, Tobias Oetiker wrote:
> > the api bump is a point you are right ... so how about calling the
> > rrdcached specific functions
> > 
> > rrdcd_*
> > 
> > then the namespace would be properly divided ...
> Most of them are already rrdc_*.  I don't see a reason to s/^rrdc/rrdcd/.

Well, rrdc_flush() already exists. In fact, rrd_cmd_flush() is just a
wrapper around that which takes care of parsing command line arguments.
So, thinking about it again, rrd_cmd_flush() does not actually provide
any further features that should be exported in librrd.

So, I'd suggest to do the following:

 * do not rename rrd_cmd_flush but rather declare it as a private symbol
   (for that to work, we'd have to move the code to rrd_tool.c though,
   since that uses the symbol)

 * restore rrd_flush() to what it used to be (in 1.3)

What do you think?


Sebastian "tokkee" Harl +++ GnuPG-ID: 0x8501C7FC +++ http://tokkee.org/

Those who would give up Essential Liberty to purchase a little Temporary
Safety, deserve neither Liberty nor Safety.         -- Benjamin Franklin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://lists.oetiker.ch/pipermail/rrd-developers/attachments/20090327/f2f96024/attachment.bin 

More information about the rrd-developers mailing list