[rrd-developers] rrd_flush.c -> rrd_flushcached.c (was Re: [PATCH] add 'flush' to language bindings)

Tobias Oetiker tobi at oetiker.ch
Tue May 26 09:17:59 CEST 2009

On Sat, Mar 28, 2009 at 12:15:02PM +0100, Tobias Oetiker wrote:
> yes dropping rrd_flush from the api is not a good idea, otoh it
> does not acomplish anything sensible in the code, so I propose the
> following:
> have rrdc_flush for the client flushing function
> and turn rrd_flush into a no-op for backward compatibility

finally getting ready to publish 1.4rc I have resolved the
rrd_flush inconsitancy by renaming

rrd_cmd_flush to rrd_flushcached and the "rrdtool flush" command
along with it.

r1812 and r1813


Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten, Switzerland
http://it.oetiker.ch tobi at oetiker.ch ++41 62 775 9902 / sb: -9900

More information about the rrd-developers mailing list